www.1862.net > tomCAt9支持jDk11吗

tomCAt9支持jDk11吗

不可以的,一般是和jdk版本保持一致的,也就是说tomcat6用>=jdk6版本就可以了.通常情况下,可以依次类推的.tomcat8.0可以兼容jdk1.6,而tomcat6.0不可以兼容jdk1.8,tomcat版本高->jdk版本低 不会出问题

是兼容的 因为两个软件的分工不同 不会相互影响的哦 所以在电脑上安装tomcat 和JDK 都是可以运行的

8 and later(来之官方文档):

一一对应的就好,比如tomcat7 和jdk7.jdk可以向下兼容tomcat,tomcat5 6 7 也可以用jdk7

tomcat不需要,但是您要运行java就必须要.

需要,这就是为什么需要配置环境变量的原因了,tomcat运行的时候会读取环境变量里面的值,比如读取java_home的值获取java.exe文件路径,然后通过该文件去启动tomcat程序.如果没有java_home那么tomcat启动就会失败.但是你配置java_home之前需要安装jdk,所以最终的结果就是你必须安装jdk

tomcat是开源的项目

暂时好像只到8

支持的,不过版本有点高.建议用1.7或者1.6版本在window -preference --myeclipse----server ---tomcat下配置tomcat;在window -preference --java---JRE下配置jdk即可.

1,修改bin文件夹下面的catalina.bat文件,把如下内容 rem ----- Execute The Requested Command ---------------------------------- echo Using CATALINA_BASE: %CATALINA_BASE% echo Using CATALINA_HOME: %CATALINA_HOME% echo Using CATALI

网站地图

All rights reserved Powered by www.1862.net

copyright ©right 2010-2021。
www.1862.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com